The main menu of the terminal is located under the program heading and represents a set of sub-menus.

Commands and functions to be executed in the client terminal are collected in it. The main menu consists of:

  • File => Working with charts, storing of history data and profiles, and print.
  • View => Setting toolbar, managing command windows ("Market Watch", "Data Window", "Navigator", "Terminal", "Tester") and the program interface language.
  • Insert => Managing technical indicators, line studies, and other objects.
  • Charts => Setting of bars displaying, scale, managing the imposed objects, presence of grid, chart properties.
  • Tools => General settings of the client terminal, History Center, global variables, and MetaEditor (MetaQuotes Language 4 editor).
  • Window => The list of open charts and their locations.
  • Help => Userguide and information about the program.

File

Commands for working with charts, managing profiles, storing history data and charts are collected in this menu, as well as charts printing properties.

The following commands are available in the menu:

  • New Chart — open a new chart window for the symbol. At the command execution, the list of available symbols will appear. Having selected a symbol from the list, one can open a new chart.
  • Open Offline — open a symbol chart offline. By this command, one will be able to select a necessary file with its history data being stored. At that, the new quotes for this symbol will not be shown in the chart. Offline chart opening can be useful at testing expert advisors.
  • Open Deleted — restore a deleted chart. The deleted charts will be restored if the "Save deleted charts to reopen" is enabled in the terminal settings. All deleted charts templates are stored in the /DELETED directory. At this command execution, these templates are called, and the corresponding chart will be opened.
  • Profiles — open sub-menu for managing profiles. Profiles can be stored or deleted from this sub-menu, as well as previously stored ones can be downloaded.
  • Close — close the current chart.
  • Save As — save history data as a text file in "CSV", "PRN", or "HTM" format.
  • Save As Picture... — save the chart in "BMP" or "GIF" format. Once you have pressed it, the window containing the alternatives of a terminal area to be saved appears: "Active workspace", "Active chart (as is)", and "Active chart" showing the specific size.The same actions can be performed by the chart context menu command of the same name.
  • Open Data Folder — open the folder there the client terminal stores its data: price history, configuration files, MQL4 programs, etc.
  • Open an Account — open a new demo account. Such accounts can be opened without placing of any money onto the deposit and allow to test the own trading system well.To open an account, one can also execute the context menu command of the same name of the "Navigator — Accounts" window or press the Insert button.
  • Login to Trade Account — authorize. At this command execution, the terminal tries to connect to the server using the account selected. After successful authorization, quotes and news will start to income, and one can start trading.It is possible to authorize having executed the "Login" command of the context menu of the "Navigator — Accounts" window or double-click on the account name.
  • Login to MQL5.community — open the settings of the trading platform to login to MQL5.community and get additional services.
  • Print Setup... — general setup of printing parameters — printing device, page size and orientation, etc.
  • Print Preview — preview the chart before printing it. The settings of the selected printer are used at this. This command helps to preview before printing whether all desired data can be printed with the settings given.
  • Print... — print a chart. If the "Color Print" option is enabled in the program settings, the chart can be printed in color, not as a black-and-white one.The same actions can be performed by pressing of the print  button of the "Standard" toolbar, accelerating buttons of Ctrl+P or by execution of the "Print" chart context menu command.
  • Exit — the terminal shutdown.

Attention: If the terminal is shut down, the expert advisors and Trailing Stops will not be executed.

Did this answer your question?